Major_Shepard

ArmA3Sync - Logiciel de lancement et de synchronisation pour addons

75 messages dans ce sujet

arma3sync_logo.png

ArmA3Sync, launcher et logiciel de synchronisation pour ArmA 3

Par la team [s.o.E] - Sons of Exiled, www.sonsofexiled.fr

Version courante 1.2

arma3sync_presentation_4.png

--- A propos ---

ArmA3Sync est une application permettant le lancement et la synchronisation des addons pour ArmA 3. Le logiciel est destiné aux joueurs, aux administrateurs de serveurs ainsi qu'aux organisations évoluant sur le jeu. Son développement a été inspiré des logiciels ArmA 2 Game Launcher (SpiritedMachine) et AddonSync 2009 (Yoma) dont ArmA3Sync en réalise la synthèse.

Les fonctionnalités principales en sont:

- La configuration et le lancement du jeu avec addons.

- La configuration et le lancement de serveurs de jeu avec addons sur les plateformes Windows voir et Linux voir.

- La construction et la gestion de dépôts d'addons personnalisés.

- La synchronisation fiable des mises à jour d'addons par transfert FTP et comparaison des sommes de contrôle SHA1.

- La diffusion d'évènements permettant de faciliter l'organisation de parties multijoueurs employant des addons voir.

--- Téléchargements ---

Installateur automatique Windows: http://www.armaholic.com/page.php?id=22199

Installation manuelle: ftp://www.sonsofexiled.fr/ArmA3/ArmA3Sync/download/

--- Prérequis ---

ArmA3Sync nécessite Java Runtime Environment 7.

--- Documentation ---

Wiki ArmA3Sync

--- Auteurs ---

[s.o.E] Major_Shepard: conception logiciel

[s.o.E] Matt2507: conception graphique & développement web

[s.o.E] & [bWF] & [F27] membres: test

[s.o.E] team, www.sonsofexiled.fr

[bWF] team, www.blackwater.fr

[F27] team, www.force27.com

--- Conditions d'utilisation ---

ArmA3Sync est un logiciel libre distribué sous la licence GNU Global Public Licence (GPL) en version 3.

Les auteurs et la team [s.o.E] rejettent toute responsabilité dans l'utilisation faite du logiciel.

Partager ce message


Lien à poster
Partager sur d’autres sites

Et encore un grand MERCI au Major pour son ingénieu systeme, adopté par la VEAF et ouf grandement pratique..

 

Good Job Major et a ceux qui ont mis la mains a la patte

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir.

 

Je poste ici car je rencontre un soucis pour l'utiliser. Je suis administrateur de l'USSAR et souhaite le déployer pour permettre une mise à jour rapide des mods. Soit, je suis le wiki à la lettre, j'ouvre un ftp sur le dédié et tente de me connecter avec le logiciel côté client, au "repository". Helas ca ne marche pas, la connexion en elle même se fait au bout d'un bon moment (je dirai une ou deux minutes), et quand je fais "check addons" j'obtiens "File ServerInfo not found". Côté serveur, sur ma console FTP, je vois que je me connecte en mode passif. Je me suis dis que c'était un problème de port, j'ai tout ouvert pour voir (TCP Entrant) et la, tout fonctionne à merveille (connexion en 2 secondes, synchronisation possible des mods). Je décide donc de trouver le port en commençant par ouvrir une plage et puis sans raisons, j'ai l'impression que le port utilisé saute pour en être un autre. J'espère me faire comprendre ^^

 

Pouvez-vous m'aider ?

 

Au passage, un grand merci pour le LEA dont je me sers souvent. Merci également pour ce programme, qui j'en suis sur si il fonctionne, doit être très efficace.

 

Cordialement.

 

 

EDIT : J'ai oublié de préciser que j'ai bien ouvert le port 21 TCP entrant, et que je me connecte dessus avec le programme.

Partager ce message


Lien à poster
Partager sur d’autres sites

Le port FTP¨par défaut est 21 oui. Il faut donc ouvrir le port en entrée et en sortie sur la machine qui accueil le serveur FTP (FileZilla?).

Partager ce message


Lien à poster
Partager sur d’autres sites

 vérifie les droits et les autorisation du compte public

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir.

 

Merci de vos réponses rapides.

 

Pour le port 21, il est bien ouvert (TCP) en sortant et entrant. Effectivement j'utilise le logiciel FileZilla.

 

Pour les droits, normalement je ne me suis pas trompé. Le compte "anonymous" a bien les droits de connexion et d’accès au dossier (et le bon) avec pour seul droit "read". J'insiste encore pour dire que si j'ouvre tout les ports en entrant ca marche.

 

Cordialement.

Partager ce message


Lien à poster
Partager sur d’autres sites

Dans les règles du parfeu ajoute l'application FileZilla server.exe en trafic entrant et sortant.

Partager ce message


Lien à poster
Partager sur d’autres sites

Juste un petit retour sur le launcher...

 

J'ai plusieurs mods installés que j'utilise de temps en temps...

 

Les voici:

@Blastcore

@CBA_A3

@tmr

@TPW_MODS

@VTS_Gesture

 

Voulant jouer sur un serveur sans mod installé, je les désactive donc avant de lancer ArmA !

 

Le problème est que malgré la désactivation des mods, le jeu les voit activé !

 

Comment je le sais ?

 

Car j'ai essayé en faisant l'opération en "manuel" pour "désactiver" ces mods, j'ai "coupé-collé" les mods sur le bureau...

 

Quelqu'un a eu ce souci ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut

Essayes de les désactiver via les options de Arma3 (Configurer/Extensions). ;)

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir, bonsoir,

 

Je voudrais mettre en place la synchro des mods sur notre serveur en utilisant votre soft.

J'ai suivi à la lettre le Wiki détaillé, ouvert les ports, créer le compte anonyme sur le FTP...

 

Et je coince à la connection depuis le coté client à "Connecting to repositery.."

Du coté serveur ça donne ça:

> Connected, sending welcome message...
> USER anonymous
> 331 Password required for anonymous
> PASS
> 230 Logged on
> TYPE I
> 200 Type set to I
> CWD /FTP/TEST_A3Sync/.a3s
> 550 CWD failed. "/FTP/TEST_A3Sync/.a3s": directory not found.
> PASV
> 227 Entering Passive Mode (62,210,131,115,0,40)
> RETR autoconfig
> 550 File not found
> disconnected.

Pas moyen de savoir d'où l'erreur peut venir et la connection depuis une instance Filezilla marche parfaitement.

 

Des idées??

 

Merci d'avance

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Apparemment il ne trouve pas le fichier d'autoconfig.

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !


Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.


Connectez-vous maintenant